CIS 221 Lab 14 Managing Computer Security Configuration


Lab 14 Managing Computer Security Configuration
This lab contains the following exercises and activities:

· Exercise 14-1: Configuring Security Options

· Exercise 14-2: Understanding Security Templates

· Exercise 14-3: Creating and Editing a Security Template

· Exercise 14-4: Using the Security Configuration And Analysis Tool

· Exercise 14-5: Using Secedit

· Exercise 14-6: Configuring Logging

· Lab Review Questions

Scenario
You have been asked to increase and standardize security across computers with similar roles. You have decided that security templates are the best way to accomplish this.

In preparation for launching a pilot run of new security templates, you are creating and testing the new templates on a test system. Included in your testing will be the creation of a template by copying a built-in template, editing a template using the Security Templates snap-in, and analysis and configuration of templates using the Security Configuration And Analysis snap-in. In some cases, you might only want to apply parts of a template, so you need to test partial deployment of a security template using the Secedit tool.

Once you have deployed your new security templates, you want to tighten security by checking Event Viewer periodically for any suspicious entries that could indicate an attack on the network.

After completing this lab, you will be able to:

· Configure local security options.

· Create and edit security templates.

· Analyze security templates in relation to current configurations.

· Apply security templates.

· Use logging for security.

Before You Begin

This lab has no prerequisites.

Exercise 14-1: Configuring Security Options

A user broke her wrist and can type with only one hand. She finds it difficult to press CTRL+ALT+DEL when logging on. You need to disable the local security option that requires this.

1. Log on locally with your Administrator account (the password is P@sswOrd)
2. From the Start menu, select Control Panel.

3. In Control Panel, ensure that you are using Classic view, and double-click Administrative Tools.

4. In the Administrative Tools window, double-click Local Security Policy.

5. In the Local Security Settings console, expand Local Policies, and then select Security Options.

6. In the details pane, right-click Interactive Logon: Do Not Require CTRL+ALT+DEL and select Properties.

7. In the Interactive Logon: Do Not Require CTRL+ALT+DEL Properties dialog box, select Enabled, Click OK.

8. Close all open windows
Exercise 14-2: Understanding Security Templates
To begin your new security rollout, you need first to understand your options when it comes to security templates. To do this, you are going to create a custom console and examine security templates.

Examining Security Templates

The following steps create a console with the Security Templates snap-in added. You can then use the snap-in to examine a security template.

1. From the Start menu, select Run.

2. In the Run dialog box, in the Open text box, type mmc and then press ENTER.

3. In the Console1 console, from the File menu, select Add/Remove Snap-In.

4. In the Add/Remove Snap-In dialog box, click Add.

5. In the Add Standalone Snap-In dialog box, select Security Templates, and then click Add. Click Close.

6. In the Add/Remove Snap-In dialog box, click OK.

7. In the Console1 console, in the console tree, expand Security Templates, C:\Windows\Security\Templates, Compatws, and then select Restricted Groups.

Question 1: What built-in group does the Compatws security template contain in the Restricted Groups folder?
8. In the console tree, expand Rootsec, and then select File System.

9. 1In the details pane, double-click %SystemDrive%\.

10. In the %SystemDrive%\ Properties dialog box, click Edit Security.

Question 2:  From examining the Security For  %SystemDrive%\ dialog box, what type of policy does the File System node seem to be responsible for defining in a template?

11. In the Security For %SystemDrive%\ dialog box, click Cancel.

12. In the %System Drive%\ Properties dialog box, click Cancel.

13. In the console tree, examine the Setup Security template node.

Question 3:  In the Setup Security template, who is allowed the user right Take Ownership Of Files Or Other Objects (Hint: User Rights Assignment node)?

14. From the File menu, select Save As.

15. In the Save As dialog box, click the Desktop icon on the left, and save the console as Security Templates.

16. Leave the Security Templates console open.

Examining Security Templates Using Notepad

Now that you have seen what a security template looks like in the Security Templates snap-in, you want to see what the raw data of a security template file looks like in Notepad.

1. From the Start menu, point to All Programs, Accessories, and then select Notepad.

2. In Notepad, from the File menu, select Open.

3. In the Open dialog box, in the Look In drop-down list, browse to C:\Windows\Security \Templates.

4. In the File Name text box, type *.* and then press ENTER.

5. Select the Compatws.inf file, and then click Open.

Question 4: In the previous task, a question about the Power Users being a restricted group in the Compatws security template was asked. What lines of code in the Compatwo.inf file are likely responsible for the fact that the Power Users are a restricted group in the template?

Question 5: The Compatws security template has by far more entries for one group of items than any other. What set of items is that?

6. Close Notepad.

Exercise 14-3: Creating and Editing a Security Template

To begin testing for your pilot run, you need to create a template. The following exercise copies an existing template and uses the Security Templates snap-in to edit it. The template needs to be edited to enable the Removable Storage service with access granted only to System, which is a necessary configuration for a proprietary backup system that Contoso, Ltd., uses for sensitive data.

1. From the Start menu, select My Computer.

2. In the My Computer window, browse to C:\Windows\Security\Templates.

3. From the File menu, click New, and then click Folder.

4. For the name of the folder, type Custom and then press ENTER.

5. Select Securews.inf, and then from the Edit menu, select Copy.

6. Double-click the Custom folder.

7. In the Custom window, from the Edit menu, select Paste.

8. Right-click Securews.inf, and then select Rename.

9. For the name of the file, type Bldg1ws.inf and then press ENTER.

10. In the Security Templates console, in the console tree, select Security Templates.

11. From the Action menu, select New Template Search Path.

12. In the Browse For Folder dialog box, browse to the Custom folder that you just created, and then click OK.

13. In the Security Templates console, in the console tree, expand C: \Windows\ Security\Templates\ Custom\ Bldg1ws.inf, and then select System Services, as shown in the following figure.

[image: image1.jpg]‘fi Security Templates - [Console Root\Security Templates\C:\WINDOWS\securitylemplatesiC.

B Fle Adion Vew Favortes Window

e @@ xR @m

Help

& [ soaurosc
& 29 Account polies
=36 Local ol

5 8 Audk pocy

5 2] User Rihts ssinmert

539 secuky Options
A tventLog

Restrcted Groups

System Services

Registry

Fie System

CH\WINDOWS\security\templates|Custom

B Hdgtws.f

& 29 Account polies

536 Local ol

3 eventLog

5 (8 Restcd roups

Regstry.
File System

[ servece ame

|| g and Py

|| @y portable Media Serial Numb.
|| Ruprintspooker

|| % protected storage

|| %05 Reve

|| R Remote AccessAuto Come.
|| fymemote access Comection
|| ® Remate Desktap Help Sessi,
|| # Remote procedure cal (RpC)
Remote Procedire Cal (RP.
Remote Regitry

Remavable Storage

Routing and Remate Access
Secondry Logon

Security Accounts Manager
Securty Center

Server

Shell Hardware Detection
Smart Card

5SDP Discovery Service

SEEEEEEEEEE

Startup
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined

Permissian
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined
ot defined





14. In the details pane, double-click Removable Storage.

15. In the Removable Storage Properties dialog box, select the Define This Policy Setting in the Template check box.

16. In the Security For Removable Storage dialog box, in the Group Or User Names list box, remove all entries except SYSTEM, as shown in the following figure.
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17.  Click OK.

18. In the Removable Storage Properties dialog box, select Automatic and then click OK.

19. In the Security Templates console, in the console tree, select Bldg1ws.inf.

20. From the Action menu, select Save.

21. Leave the Security Templates console open.

Exercise 14-4: Using the Security Configuration and Analysis Tool
Now that you have a new security template, you want to compare its security settings with those of the system to which it will be applied. This will give you a warning of any possible conflicts that installing the new template might cause.

To determine how much your computer's security differs from a security template (or combination of security templates), you must first create a database to contain the template(s) and then use the Security Configuration  And Analysis snap-in.

Using the Security Configuration And Analysis Tool for Analysis

The following steps will analyze the Bldg1lws security template by comparing it to your existing security configuration.

1. In the Security Templates console, from the File menu, select Add/Remove Snap-In.

2. In the Add/Remove Snap-In dialog box, click Add.

3. In the Add Stand-Alone Snap-In dialog box, select Security Configuration And Analysis and then click Add. Click Close.

4. In the Add/Remove Snap-In dialog box, click OK.

5. In the Security Templates console, in the console tree, right click Security Configuration And Analysis, and from the Action menu, select Open Database.

6. In the Open Database dialog box, in the File Name text box, type Bldg1SecDB and then click Open.

7. In the Import Template dialog box, select Securews.inf, and then click Open.

8. In the Security Templates console, in the console tree, select and right-click Security Configuration And Analysis, and then select Analyze Computer Now.

9. In the Perform Analysis message box, (make note of the path to the file) click OK to accept the default path for the error log file,.

10. An Analyzing System Security status box will appear while your system is analyzed. Wait for the analysis to finish before moving to the next step.
11. In the console tree, expand Security Configuration And Analysis, expand Local Policies, and then select Audit Policy.

Question 6:  In the details pane, what does the red X flag on the Audit Account Logon Events policy icon denote? (Hint: look at the items in the Database Setting and Computer Setting column.)

12. In the console tree, select Security Options.

Question 7: In the details pane, what does the green check mark flag on the Accounts: Guest Account Status policy icon denote?

13. In the console tree, select System Services.

Question 8:  Is there a flag on the Removable Storage service? If so, describe it. 
14. In the console tree, select and then right-click Security Configuration And Analysis, and then select Import Template.

15. In the Import Template dialog box, navigate to C:\Windows\Security \Templates\Custom, and then select Bldg1ws.inf. Click Open.

16. From the Action menu, select Analyze Computer Now.

17. In the Perform Analysis message box, click OK to accept the default path for the error log file.

18. An Analyzing System Security status box will appear while your system is analyzed. Wait for the analysis to finish before moving to the next step.

19. Navigate to System Services under the Security Configuration And Analysis node.

Question 9: What flag marks the Removable Storage service now?

20. In the Security Templates console, in the console tree, select and then right-click Security Configuration And Analysis, and then select Export Template.

21. In the Export Template To dialog box, select  Bldg1ws.inf, and then click Save.

22. In the Security Templates console, from the File menu, select Save.

23. Leave the Security Templates console open.

Using the Security Configuration And Analysis Tool for Configuration

To deploy your new template on the local machine, you will use the Security Configuration  And Analysis snap-in.

1. In the Security Templates console, in the console tree, select and then right-click Security Configuration And Analysis, and then select Configure Computer Now.

2. In the Configure System dialog box, click OK to accept the default path for the error log.

3. In the Security Templates console, in the console tree, select and then right-click Security Configuration And Analysis, and then select Analyze Computer Now.

4. In the Perform Analysis dialog box, click OK to accept the default path for the error log.

5. An Analyzing System Security status box will appear while your system is analyzed.

6. In the console tree, under Security Configuration And Analysis, expand Local Policies, and then select Audit Policy.

Question 10: In the details pane, why is there no longer a red X flag on the Audit Account Logon Events policy icon?

7. Close the Security Templates console. In the Microsoft Management Console message box asking if you want to save changes, click Yes.

Exercise 14-5: Using SECEDIT
Using Secedit to Partially Apply a Security Template

The following steps will apply only the registry keys section of the Bldg1ws security template.

1. From the Start menu, select Run.

2. In the Run dialog box, type cmd and then press ENTER.

3. In the command prompt window, at the command prompt, type                  cd C:\Windows\Security\Templates\Custom and then press ENTER

4. At the command prompt, type 
 secedit /configure /db temp.sdb /cfg bldg1ws.inf /areas regkeys and then press ENTER. The results are shown in the following figure.
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5. Leave the command prompt window open
Using Secedit to Validate a Template File

You have created a custom security template using a text editor, and before you apply it to a test system, you want to make sure that it is valid (has no errors).

1. Open the C:\Windows\ Security\Templates\ Custom \ Bldg1ws.inf file in Notepad.

2. In the [System Access] section, in a new first line, type This will cause an error.

3. From the File menu, select Save As.

4. In the Save As dialog box, in the File Name text box, type Example.inf, and then press ENTER. Close Notepad.

5. In the command prompt window, at the command prompt, type 
secedit /validate Example.inf, and then press ENTER.

Question 11: What problem did the Secedit tool report?

6. Close the command prompt window and the Security Templates console.

Exercise 14-6: Configuring Logging

You have received an e-mail message from an employee who saw a suspicious-looking character at a workstation that was not his, trying to log on. Because most IT employees look suspicious, you suspect it was a member of your own IT team, conducting legitimate company business. But you decide to ensure that the correct logging options are configured on the workstation and to check the logs periodically.
1. From the Start menu, select Control Panel.

2. In Control Panel, ensure that you are using Classic view, and double-click Administrative Tools.

3. In the Administrative Tools window, double-click Local Security Policy.

4. In the Local Security Settings console, expand Local Policies, and then select Audit Policy.

5. In the details pane, double-click Audit Logon Events.

Question12: By default, does the Audit Logon Events policy log success​ful logons?

6. Click OK.

7. Log off, and attempt to log back on as Administrator three times with​out a password.

8. Log on locally as Administrator.

9. From the Start menu, right-click My Computer and then select Manage.

10. In the Computer Management console, expand Event Viewer, and then select Security.
11. In the details pane, locate a Failure Audit with a Category of Account Logon, as shown in the following figure. Double-click the event.
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Question 13:  According to the Event Properties dialog box, what Event ID is assigned to a failed, local logon attempt?

12. In the Event Properties dialog box, click OK.

13. Close the Computer Management console

Lab Review Questions

1. Currently, users are able to shut down a multiuser workstation without logging on. This means that anybody can shut down the computer, as long as nobody is logged on. You want to configure the workstation so that it cannot be shut down when nobody is logged on. How can you do this? (Hint: see Exercise 14-1.)

2. In which type of file are security templates stored?

3. When importing multiple templates into a database, how are conflicts resolved?

4. What are the four flags that are possible when using the Security Configuration And Analysis snap-in, and what do they denote?

5. You suspect that a user is logging on and trying to access network resources that require credentials. Which auditing policy will help you to determine if this is so, Audit Account Logon Events or Audit Logon Events?
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